Help with gravermax

Curtisgil

New Member
Joined
Jul 15, 2021
Messages
3
I just got a new gravermax g8 and it worked great for a couple of days
But now as soon as I try to turn it on it cuts off instantly
I unplug then replug and the same thing happens
Has anyone encountered this?
Thank you
 

Sam

Chief Administrator & Benevolent Dictator
Staff member
Joined
Nov 6, 2006
Messages
10,424
Location
Covington, Louisiana
I just got a new gravermax g8 and it worked great for a couple of days
But now as soon as I try to turn it on it cuts off instantly
I unplug then replug and the same thing happens
Has anyone encountered this?
Thank you

Where did you buy it from? Are you sure it's a genuine GRS product? Sorry for asking but there are lots of counterfeits out there.

Call 800-835-3519 and they can help you. I personally have never experienced it so I'm not sure what to advise.
 

Sinterklaas

Elite Cafe Member
Joined
Dec 19, 2015
Messages
149
Location
Holland
First start your compressor so it can get up to pressure.
Then turn on the Gravermax. Check if the pressure is good on the Gravermax. If not turn knob.
Maybe the pressure is to low. Or some thing has gotten loose inside. You can easily open it up and check if the hoses are connected inside. They are almost all quick connect hoses.

You can always call or mail GRS for help.
 

mitch

:::Pledge Member:::
::::Pledge Member::::
Joined
Jul 23, 2007
Messages
2,533
But now as soon as I try to turn it on it cuts off instantly
I unplug then replug and the same thing happens
Define "cuts off", please. Does the motor, or whole machine, shut off? Or can you hear it running, but the pulsed airflow quits and the handpiece won't work? I assume by "unplug then replug" you mean the electrical plug in the wall outlet?
 

Curtisgil

New Member
Joined
Jul 15, 2021
Messages
3
It’s as if it kicks a breaker right as I turn it on. Whole machine shuts off
the little green light on the power supply goes out
I’ve tried multiple power outlets
 

mitch

:::Pledge Member:::
::::Pledge Member::::
Joined
Jul 23, 2007
Messages
2,533
the curious part is that it WILL come back on, if only for a moment, when you plug it back in, so it's not a fuse or breaker. if it was a car your mechanic would just plug in the OBDII and say, "Well, there's yer problem, right there. Your blinker fluid is low and that's causing static to build up in your floormats..."
 

Sam

Chief Administrator & Benevolent Dictator
Staff member
Joined
Nov 6, 2006
Messages
10,424
Location
Covington, Louisiana
It’s as if it kicks a breaker right as I turn it on. Whole machine shuts off
the little green light on the power supply goes out
I’ve tried multiple power outlets

Do you have a genuine GRS product or not? We need to know that first. Where did you buy the machine?
 

Sam

Chief Administrator & Benevolent Dictator
Staff member
Joined
Nov 6, 2006
Messages
10,424
Location
Covington, Louisiana
Yes purchased from GRS
That's a relief. At least now you know it can be fixed. Not much can be done with the fakes.
I'm assuming you've called them by now. Talk to Greg @ GRS and he'll get you squared away. Or call their toll free number and ask to speak to Rex Pedersen. He's also a GRS technical guru who can assist with troubleshooting.
 

Latest posts

Sponsors

Top